Создание кроссворда в программе microsoft excel

Создание автопроверки

Но, Excel позволяет сделать не просто кроссворд, но и кроссворд с проверкой, в котором сразу автоматически будет отражаться правильно пользователь разгадал слово или нет.

Для этого, в этой же книге на новом листе делаем таблицу. Первый её столбец будет называться «Ответы», и мы туда впишем ответы на кроссворд. Второй столбец будет назваться «Введено». Тут отображаются данные, введенные пользователем, которые будут подтянуты из самого кроссворда. Третий столбец будет называться «Совпадения». В нём, если ячейка первого столбца будет совпадать с соответствующей ячейкой второго столбца, отобразиться цифра «1», а иначе – «0». В этом же столбце внизу можно сделать ячейку для общей суммы отгаданных ответов.

Теперь, нам посредством формул предстоит связать таблицу на одном листе с таблицей на втором листе.

Было бы просто, если каждое слово кроссворда пользователь вводил в одну ячейку. Тогда бы мы просто связали ячейки в столбце «Введено» с соответствующими ячейками кроссворда. Но, как мы знаем, в каждую ячейку кроссворда вписывается не одно слово, а одна буква. Воспользуемся функцией «СЦЕПИТЬ», чтобы объединить эти буквы в одно слово.

Итак, кликаем по первой ячейке в столбце «Введено», и жмем на кнопку вызова Мастера функций.

В открывшемся окне Мастера функций, находим функцию «СЦЕПИТЬ», выделяем её, и кликаем по кнопке «OK».

Открывается окно аргументов функции. Кликаем на кнопку, расположенную справа от поля ввода данных.

Окно аргументов функции сворачивается, а мы переходим на лист с кроссвордом, и выбираем ячейку, где расположена первая буква того слова, которое соответствует строчке на втором листе документа. После того, как выбор сделан, опять жмем на кнопку слева от формы ввода, чтобы вернуться в окно аргументов функции.

Подобную операцию проделываем с каждой буквой слова. Когда все данные введены, жмем на кнопку «OK» в окне аргументов функции.

Но, пользователь при разгадывании кроссворда может использовать как строчные, так и прописные буквы, а программа будет расценивать их как разные символы. Для того, чтобы этого не случилось, становимся на нужную нам ячейку, и в строке функций прописываем значение «СТРОЧН». Остальное все содержимое ячейки берем в скобки, как на изображении ниже.

Теперь, какими бы буквами не писали пользователи в кроссворде, в столбце «Введено» они будут преобразовываться в строчные.

Подобную процедуру с функциями «СЦЕПИТЬ» и «СТРОЧН», нужно проделать с каждой ячейкой в столбце «Введено», и с соответствующим ей диапазоном ячеек в самом кроссворде.

Теперь, для того, чтобы сравнить результаты столбца «Ответы» и «Введено», нам в столбце «Совпадения», нужно использовать функцию «ЕСЛИ». Становимся на соответствующую ячейку столбца «Совпадения», и вводим функцию такого содержания «=ЕСЛИ(координаты столбца «Ответы»=координаты столбца «Введено»;1;0). Для нашего конкретного случая из примера, функция будет иметь вид «=ЕСЛИ(B3=A3;1;0)». Подобную операцию проделываем для всех ячеек столбца «Совпадения», кроме ячейки «Итого».

Затем выделяем все ячейки в столбце «Совпадения», включая ячейку «Итого», и кликаем по значку автосуммы на ленте.

Теперь на данном листе будет проводиться проверка правильности разгаданного кроссворда, а результаты правильных ответов будут отображаться в виде общего балла. В нашем случае, если кроссворд будет разгадан полностью, то в ячейке суммы должно появиться число 9, так как общее количество вопросов равно этому числу.

Чтобы результат разгадывания был виден не только на скрытом листе, но и тому человеку, который разгадывает кроссворд, можно опять воспользоваться функцией «ЕСЛИ». Переходим на лист, содержащий кроссворд. Выбираем ячейку, и вводим туда значение по такому шаблону: «=ЕСЛИ(Лист2!Координаты ячейки с общим баллом=9;«Кроссворд разгадан»;«Подумайте ещё»)». В нашем случае, формула имеет такой вид:«=ЕСЛИ(Лист2!C12=9;«Кроссворд разгадан»;«Подумайте ещё»)».

Таким образом, кроссворд в программе Microsoft Excel полностью готов. Как видим, в этом приложении можно не просто быстро сделать кроссворд, но и создать в нём автопроверку.

Мы рады, что смогли помочь Вам в решении проблемы.

Помогла ли вам эта статья?

Да Нет

Кроссворд — это та головоломка, которую знают все. В настоящее время есть много вариаций данного развлечения, но одно сказать можно точно — кроссворды любят разгадывать многие. Из этого вытекает и то, что есть люди, которые любят их создавать.

Создание кроссворда может потребоваться в разных целях. Кто-то их делает для проверки знаний учащихся, а кто-то для себя и своих знакомых. Если же вы решили впервые создать собственную головоломку, то программа Excel вам в этом поможет.

Создание автопроверки

Но, Excel позволяет сделать не просто кроссворд, но и кроссворд с проверкой, в котором сразу автоматически будет отражаться правильно пользователь разгадал слово или нет.

Для этого, в этой же книге на новом листе делаем таблицу. Первый её столбец будет называться «Ответы», и мы туда впишем ответы на кроссворд. Второй столбец будет назваться «Введено». Тут отображаются данные, введенные пользователем, которые будут подтянуты из самого кроссворда. Третий столбец будет называться «Совпадения». В нём, если ячейка первого столбца будет совпадать с соответствующей ячейкой второго столбца, отобразиться цифра «1», а иначе – «0». В этом же столбце внизу можно сделать ячейку для общей суммы отгаданных ответов.

Теперь, нам посредством формул предстоит связать таблицу на одном листе с таблицей на втором листе.

Было бы просто, если каждое слово кроссворда пользователь вводил в одну ячейку. Тогда бы мы просто связали ячейки в столбце «Введено» с соответствующими ячейками кроссворда. Но, как мы знаем, в каждую ячейку кроссворда вписывается не одно слово, а одна буква. Воспользуемся функцией «СЦЕПИТЬ», чтобы объединить эти буквы в одно слово.

Итак, кликаем по первой ячейке в столбце «Введено», и жмем на кнопку вызова Мастера функций.

В открывшемся окне Мастера функций, находим функцию «СЦЕПИТЬ», выделяем её, и кликаем по кнопке «OK».

Открывается окно аргументов функции. Кликаем на кнопку, расположенную справа от поля ввода данных.

Окно аргументов функции сворачивается, а мы переходим на лист с кроссвордом, и выбираем ячейку, где расположена первая буква того слова, которое соответствует строчке на втором листе документа. После того, как выбор сделан, опять жмем на кнопку слева от формы ввода, чтобы вернуться в окно аргументов функции.

Подобную операцию проделываем с каждой буквой слова. Когда все данные введены, жмем на кнопку «OK» в окне аргументов функции.

Но, пользователь при разгадывании кроссворда может использовать как строчные, так и прописные буквы, а программа будет расценивать их как разные символы. Для того, чтобы этого не случилось, становимся на нужную нам ячейку, и в строке функций прописываем значение «СТРОЧН». Остальное все содержимое ячейки берем в скобки, как на изображении ниже.

Теперь, какими бы буквами не писали пользователи в кроссворде, в столбце «Введено» они будут преобразовываться в строчные.

Подобную процедуру с функциями «СЦЕПИТЬ» и «СТРОЧН», нужно проделать с каждой ячейкой в столбце «Введено», и с соответствующим ей диапазоном ячеек в самом кроссворде.

Теперь, для того, чтобы сравнить результаты столбца «Ответы» и «Введено», нам в столбце «Совпадения», нужно использовать функцию «ЕСЛИ». Становимся на соответствующую ячейку столбца «Совпадения», и вводим функцию такого содержания «=ЕСЛИ(координаты столбца «Ответы»=координаты столбца «Введено»;1;0). Для нашего конкретного случая из примера, функция будет иметь вид «=ЕСЛИ(B3=A3;1;0)». Подобную операцию проделываем для всех ячеек столбца «Совпадения», кроме ячейки «Итого».

Затем выделяем все ячейки в столбце «Совпадения», включая ячейку «Итого», и кликаем по значку автосуммы на ленте.

Теперь на данном листе будет проводиться проверка правильности разгаданного кроссворда, а результаты правильных ответов будут отображаться в виде общего балла. В нашем случае, если кроссворд будет разгадан полностью, то в ячейке суммы должно появиться число 9, так как общее количество вопросов равно этому числу.

Чтобы результат разгадывания был виден не только на скрытом листе, но и тому человеку, который разгадывает кроссворд, можно опять воспользоваться функцией «ЕСЛИ». Переходим на лист, содержащий кроссворд. Выбираем ячейку, и вводим туда значение по такому шаблону: «=ЕСЛИ(Лист2!Координаты ячейки с общим баллом=9;«Кроссворд разгадан»;«Подумайте ещё»)». В нашем случае, формула имеет такой вид:«=ЕСЛИ(Лист2!C12=9;«Кроссворд разгадан»;«Подумайте ещё»)».

Таким образом, кроссворд в программе Microsoft Excel полностью готов. Как видим, в этом приложении можно не просто быстро сделать кроссворд, но и создать в нём автопроверку.

Кроссворды любят разгадывать все. Это чрезвычайно полезная вещь, которая пригодится в разных сферах деятельности: для привлечения пользователей на ресурс, для проверки и закрепления знаний в ходе преподавания и др.

Электронные таблицы Excel позволяют «автоматизировать» разгадывание кроссвордов: пользователю сразу видны результаты решения. Создадим их с помощью стандартных функций.

Как сделать кроссворд в excel с проверкой и оценкой?

Проверка правильности решения кроссворда.

Чтобы проверить, правильно ли ученик заполнил кроссворд, нужно сравнить каждое введенное слово с образцом – правильным ответом. Иначе говоря, для каждого слова мы будем сравнивать значения двух ячеек – с введенным словом и правильным ответом, и если они равны, помечать это слово как «верно».

Запишем на свободном месте листа Excel правильные ответы (потом эта информация будет скрыта).

Но если правильный ответ представляет из себя целое слово, записанное в одной ячейке, то ответ ученика – это совокупность нескольких ячеек, в каждой из которых записано по одной букве. Поэтому мы должны ответ ученика преобразовать так, чтобы его можно было сравнить с правильным ответом, то есть соединить отдельные буквы из разных ячеек в целое слово, записанное в одной ячейке. Для этого будем использовать функцию для текстовых величин СЦЕПИТЬ.

· Выделите ячейку, в которой будет записан преобразованный ответ ученика (в моем примере это ячейка, в которой записаны ответы студента ).

· В данной ячейке введите формулу (наберите с клавиатуры или воспользуйтесь командой Вставить функцию на вкладке Формулы): =СЦЕПИТЬ ( ячейка с первой буквой слова; ячейка со второй буквой слова ; ячейка с третьей буквой слова ; т.д.; ).

Теперь можно сравнить правильный ответ с ответом ученика. Для этого будем использовать функцию ЕСЛИ: если слова совпадут, напишем напротив ответа «1», если нет «0». Мы используем числовые значения, а не слова «верно» — «неверно», потому что в дальнейшем проще будет подсчитать количество правильно угаданных слов.

Введите в ячейку : =ЕСЛИ(ячейка с правильным ответом=ячейке с ответом студента;1;0).

С помощью маркера автозаполнения копируем формулу по столбцу на весь необходимый диапазон.

· Ниже напишите «Количество правильных ответов» и введите в соседнюю ячейку формулу: = СУММ(первая ячейка с правильностью ответов: последняя ячейка с правильностью ответов )

Скройте все строки с ответами ученика, правильными ответами и количеством угаданных слов.

Пусть в процессе разгадывания кроссворда на экране высвечивается комментарий «Отлично!», «Хорошо!», «Пока на «троечку»», «Пока не угадано ни одного слова». Для этого введите в ячейку формулу:

=ЕСЛИ(ячейка с количеством отгаданных слов=0;»Пока не угадано ни одного слова»;ЕСЛИ( ячейка с количеством отгаданных слов ячейка с количеством отгаданных слов

Создадим кнопку для очистки ячеек кроссворда с использованием макроса.

Нажмите кнопку « Office » , затем «Параметры Excel », выберите в списке с левой стороны открывшегося окна «Настройка», затем из списка вкладок выберите «Разработчик».

В списке команд найдите «Элементы управления» и нажмите кнопку «Добавить», затем кнопку «ОК». Кнопка «Элементы управления» будет добавлена на панель быстрого доступа.

На панели быстрого доступа нажмите кнопку «Элементы управления», «Вставить», «Элементы управления формы», «Кнопка».

Нарисуйте кнопку. Автоматически откроется окно «Назначить макрос объекту». Нажмите на кнопку «Записать», затем «ОК».

Выделите последовательно все клетки кроссворда и удалите из них буквы.

На вкладке Вид выберите Макросы- Остановить запись.

Теперь щелчок левой кнопкой мыши будет запускать макрос, а щелчок правой кнопкой – вызывать контекстное меню.

Чтобы изменить название кнопки, выберите в контекстном меню «Изменить текст» и введите свое название (Очистить кроссворд).

Для правильного функционирования макроса не забудьте перед работой уровень безопасности макроса выбрать Низкий: кнопка Office – Параметры Excel – Центр управления безопасности – Параметры центра – управление безопасностью – Параметры макросов – Включить макросы.

Проверьте работу кроссворда (выставление оценки и кнопку очистки кроссворда).

Первый способ: обычное копирование

Итак, в первую очередь разберем самый простой способ того, как из Excel таблицу перенести в Word:

  • В первую очередь вам необходимо открыть вордовский документ, в который вы хотите вставить таблицу, а также программу «Эксель» с той самой таблицей.
  • Теперь в «Экселе» выделите тот фрагмент, который хотите переместить в «Ворд».
  • Его необходимо скопировать. Сделать это можно тремя способами. Первый — нажать правую кнопку мыши (ПКМ) по выделенной области и в контекстном меню выбрать пункт «Копировать». Второй — нажать соответствующий значок на панели инструментов, который расположен в области «Буфер обмена». Его точное местонахождение можете увидеть на изображении ниже. Третий способ наипростейший — вам необходимо нажать сочетание клавиш CTRL+C.
  • После того как элемент скопирован, переходите к документу «Ворд». Сначала нажмите левой кнопкой мыши (ЛКМ) в том месте, куда хотите вставить таблицу.
  • Теперь ее необходимо непосредственно вставить. Сделать это можно так же тремя способами. Открыть контекстное меню, нажатием ПКМ, и в меню выбрать пункт «Сохранить исходное форматирование». Нажать на панели инструментов соответствующий значок. Его расположение вы так же можете наблюдать на изображении ниже. Третий же подразумевает использование горячих клавиш, только на этот раз CTRL+V.

По итогу, таблица будет вставлена. Это был первый способ, как перенести таблицу из Excel в Word 2007. К слову, данная инструкция будет пригодна и к другим версиям программы, хоть и с некоторыми изменениями.

Как правильно сделать кроссворд?

Сейчас существует множество компьютерных программ, с помощью которых можно просто и быстро создать головоломку или шараду в электронном виде. В работе с детьми он также выступает способом интерактивного общения

В работе со специальными программами очень важно делать все правильно, ведь, например, Excel имеет свои команды

Как сделать кроссворд правильно, чтобы он смог заинтересовать детишек? В первую очередь перед созданием такой головоломки нужно определиться с тематикой. Лучше всего набросать некий черновик на бумаге с вопросами и ответами, так будет проще ориентироваться в дальнейшей работе. Главным в кроссворде выступает слово-загадка, его можно составить из первых букв слов. Теперь можно приступать к работе с программами.

Как сделать кроссворд в «Опен Офис»?

OpenOffice в своей работе очень похож на программу «Эксель». Их главное отличие заключается в том, что первая абсолютно бесплатна (в отличие от пакета «Майкрософт»). Как же сделать кроссворд в «Опен Офис» и отличается ли эта работа от создания головоломки в «Эксель»?

В OpenOffice создавать головоломку можно так же, как и в Excel:

  • растянуть ячейки до нужного размера, сформировать квадрат;
  • выделить клеточки в нужной форме;
  • пронумеровать ячейки и ввести слова;
  • выделить с помощью заливки ключевое слово;
  • написать вопросы.

Чаще всего эта программа встречается на операционной системе Linux. Помимо «Опен Офис» нарисовать головоломку можно и в «Либре Офис». Сама программа напоминает по своей работе «Ворд». Написание загадки в LibreOffice такое же, как и в платном аналоге от Майкрософт.

Создаем кроссворд в Word

Самым простым способом создания кроссворда на компьютере является использовании для этой цели программы Word или Excel. И в той и другой программе офисного пакета Microsoft, создание сетки кроссворда заключается в форматировании ячеек таблицы. Давайте рассмотрим создание сетки в текстовом редакторе.

Заходим во вкладку «Вставка» и выбираем «Таблица». С помощью всплывающего меню выбираем количество столбцов и строчек нашей таблицы.

Меню «Таблица»

Если предложенного в шаблоне Word количества 10×8 мало, то выбрать большее количество ячеек можно с помощью пункта «Вставить таблицу».

Вставить таблицу

В нем можно создать сетку с большим количеством ячеек. Мы же выберем 10×10. Для нашего первого кроссворда это самый удобный вариант.

Выбираем число ячеек

У нас должна получиться вот такая сетка.

Исходная сетка

Конечно, пока наша сетка и близко не похожа на кроссворд. Поэтому, переходим ко второму шагу. А именно, выравниваем ячейки и делаем их квадратными. Для этого выделяем сетку и из выпавшего меню выбираем «Свойства таблицы».

Свойства таблицы

В окне свойств выбираем вкладку «Строка» и устанавливаем высоту строки. В поле режим нужно выбрать «Точно».

Задаем высоту строки

Теперь переходим к вкладке «Ячейка» и устанавливаем ее ширину равную высоте строки.

Задаем ширину ячейки

В результате сетка получилась ровной формы, а ячейки квадратными.

Сетка с квадратными ячейками

Эту сетку теперь можно использовать для создания простого кроссворда.

Теперь можно задать другие, нужные в создании кроссворда, параметры таблицы. Задаем выравнивание текста в таблице по левому верхнему углу. Сделать это можно пункте «Выравнивание ячеек», который можно выбрать из выпадающего меню после выделения всех ячеек и клика правой кнопкой мыши.

Выравниваем текст в ячейках

Затем выбираем более оптимальный для нашей таблицы шрифт. Для таблицы, в которой ячейки имеют ширину и высоту 1 см подойдет Arial с размер шрифта 9 пикселей.

Выбираем размер текста в ячейках

С помощью этого шрифта мы будем задавать нумерацию слов в кроссворде. Должно получиться что-то похожее на это:

Сетка с цифрами

После таких подготовительных работ переходим к формированию кроссворда в Word. Заполним пустые ячейки, то есть те, в которых не будет вписана буква, в черный цвет. А внешние ячейки, которые не будут использоваться в этом кроссворде просто удалим.

Залить ячейки черным (или любым другим цветом), можно установив курсор на выбранной ячейке, затем выбрать вкладку «Конструктор» и нажать на кнопку «Заливка».

Заливка неиспользованных ячеек

Что касается ненужных внешних ячеек, то их можно удалить с помощью элемента «Ластик». Он также находится во вкладке «Конструктор».

Инструмент «Ластик»

После удаления внешних ячеек и заливки неиспользуемых внутренних должна получиться сетка, которая внешне напоминает сетку кроссворда. Да, она слишком простая и маленькая, но благодаря ее созданию вы поймете, как делать сетки для самой популярной головоломки.

Сетка для кроссворда

Вам останется только расставить номера слов в ячейки и составить перечень вопросов для них.

Как создать кроссворд онлайн

Сделать головоломку не так просто, как кажется на первый взгляд. Создать саму сетку можно с помощью практически любого онлайн-сервиса, но сами вопросы к кроссворду, скорее всего, придется печатать в каком-либо текстовом редакторе. Естественно, существуют онлайн-сервисы, которые позволяют осуществить все манипуляции и без помощи сторонних программ, но для неопытных юзеров они могут оказаться слишком тяжелыми.

Способ 1: Biouroki

Один из наиболее простых сервисов, который сам генерирует головоломку по заданным ключевым словам. Основной недостаток сайта – вопросы для кроссворда придется писать в отдельном документе.

Работа на сайте осуществляется таким образом:

  1. Кликните на строку «Создать кроссворд», которая расположена под заголовком «Мастерская».

В открывшемся окне укажите ключевые слова. Писать их следует последовательно через запятую.
Кликните на кнопку «Создать» и выберите наиболее оптимальный внешний вид кроссворда.
Определите наиболее предпочтительную головоломку и кликните на строку «Сохранить…». Вы можете скачать кроссворд в виде изображения в расширении PNG или как таблицу, в которую можно будет в дальнейшем вносить изменения.

Готовую головоломку можно использовать как в электронном варианте, так и отправить на печать.

Способ 2: Puzzlecup

Работа с этим сервисом отличается от того, что рассматривалось выше. Вам необходимо самостоятельно определять местоположение строк, а также придумывать ответы на вопросы. На сервисе предусмотрена библиотека, которая помогает указать слова, основываясь на количестве клеток и имеющихся букв. К сожалению, функция автопобора не всегда помогает сделать тематическую головоломку, поэтому ключевые слова желательно придумывать самому. Вопросы к кроссворду пишутся во встроенном редакторе.

Для того чтобы создать головоломку, выполните такие действия:

  1. Кликните по любой клетке в рабочем поле, после чего отмерьте длину слова (ЛКМ). Место для него будет отмечено серым цветом.
  2. После того как вы отпустите клавишу на мышке, цвет сетки станет желтым. В правой части окна вы сможете самостоятельно вписать нужное слово или выбрать один из готовых вариантов.

Таким же образом создайте остальной кроссворд.
Кликните на любую из строк, после чего справа отобразится поле для ввода вопроса. Пропишите задание для каждого из слов.

Для того чтобы загрузить головоломку на компьютер, нажмите на пункт «Версия для печати» или «Скачать для Word». Если вы кликните на строку «Сохранить…», то документ сохранится в куках и воспользоваться им будет крайне проблематично.
При желании распечатать кроссворд можно прямо с сайта. Для этого просто нажмите на пункт «Версия для печати» и кликните ПКМ по изображению головоломки. В отобразившемся списке выберите вариант «Печать».

Способ 3: Crosswordus

Один из наиболее функциональных сервисов для создания кроссвордов. На сайте вы сможете найти подробную инструкцию, а также ознакомиться с проектами других пользователей.

Чтобы создать головоломку, проделайте такие шаги:

  1. Нажмите на строку «Создать кроссворд». В следующем окне нарисуйте поле для ввода слова. Сделать это можно с помощью боковой правой панели или обычного выделения мышкой.
  2. Выберите подходящий ответ из предложенного списка или введите его вручную на клавиатуре.

Точно таким же образом сделайте остальной кроссворд.
Кликните на одну из строк, после чего придумайте вопрос к слову. Сделать это можно под заголовком «Вопросы», нажав на надпись «Новый вопрос».
В открывшемся окне кликните на пункт «Добавить определение» и пропишите вопрос.

При желании вы можете указать тему и язык для вопроса. Это необязательная процедура, если вы планируете использовать головоломку только в личных целях.
Кликните на пункт «Добавить». Таким образом, вы сможете увидеть вопрос, который прикреплен к определенному слову, в правой рабочей области окна в блоке «Слова…».
После того как определите вопросы для каждой из строк, кликните на пункт «Сохранить», после чего в отобразившемся списке выберите вариант «Печать».
Если вдруг вы не указали вопрос к какому-то слову, то на экране отобразится оповещение, в котором это можно будет сделать.
В следующей вкладке определите настройки для печати и кликните по соответствующей кнопке.
В открывшемся окне нажмите на строку «Печать». Если вдруг такого пункта не будет на странице, то кликните ПКМ по изображению и в отобразившемся меню выберите вариант «Печать…».

Как видите, в интернете можно найти множество сервисов для создания кроссвордов. Все они работают по схожему алгоритму, но отличаются друг от друга обилием опций и инструментов.

Безопасность данных – превыше всего!

Оцените статью
Рейтинг автора
5
Материал подготовил
Андрей Измаилов
Наш эксперт
Написано статей
116
Добавить комментарий